LTI Provider plugin updated for Moodle 2.9

September 19th, 2015

LTI provider plugin for Moodle which is maintained by Juan Leyva, has been updated to a new version to support Moodle 2.8 & 2.9.

LTI provider plugin is a local plugin for making Moodle a LTI provider tool. This plugin allow remote systems users (LTI consumers) access to Moodle courses or Moodle activities inside a course (other Moodle installations, Sakai, any LMS LTI consumer compliant).

Moodle (2.2 and onwards) contains a LTI consumer tool named as External Tool which enables Moodle users to interact with LTI-compliant learning resources and activities on other web sites.

Main Features of LTI provider plugin are:

  • Provide access to full courses or single activities.
  • Single sign on
  • Change the navigation block of a course or activity for displaying information and links only regarding to your current course.
  • Send backs course or activity final grades to the LTI consumer tool
  • Modify the course or activity page for hiding the header, footer and left or right blocks.

You can download the latest version of the LTI provider plugin from the Moodle plugins database here: and if you face any problems with LTI provider plugin then you can use this support forum.

Do let us know about your experience with the LTI provider plugin in the comments below.