Decide Moodle 3.1 requirements before 30 Nov – MDL-51580

November 26th, 2015

Development work has started for Moodle 3.1, which will be the next stable release of Moodle LMS and is scheduled to be released on May 2016. Moodle 3.1 will also be an LTS version similar to the lines of Moodle 2.7 which was the first LTS version from Moodle.

In a recent Moodle Tracker issue MDL-51580, opinions by the Moodle Community members are sought to decide the PHP/DB/Moodle versions requirements for Moodle 3.1 and push them to environment.xml

The due date for the tracker issue to vote is 30 Nov and the issue is created by Eloy Lafuente.MDL-51580 Decide Moodle 3.1 requirements

According to the tracker issue description:

We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

At the same time, if there is any change in the PHP version… some changes have to be populated to various installers and replace them by the new one when corresponding.

If you are also a developer then you can vote for the requirements for Moodle 3.1 in the Moodle Tracker here.